can't run gnucash 2.0.1 on SuSE 10.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

can't run gnucash 2.0.1 on SuSE 10.0

Steve Kelem-3
I gave up on trying to compile gnucash-2.0.1 on SuSE 10.0.

Now I tried downloading rpms:
aqbanking-2.2.0-0.oc2pus.1.i586.rpm
gengetopt-2.17-0.oc2pus.1.i586.rpm
gnucash-2.0.1-0.rauch.1.i686.rpm
gnucash-2.0.1-0.rauch.2.i686.rpm
gwenhywfar-2.3.1-0.oc2pus.1.i586.rpm
g-wrap-1.9.6-0.rauch.3.i686.rpm
ktoblzcheck-1.11-42.oc2pus.1.i586.rpm
libchipcard2-2.1.7-0.oc2pus.1.i586.rpm
libgeier-0.6-0.rauch.1.SuSE1000.i686.rpm
libofx-0.8.1-1.oc2pus.cvs20060802.i586.rpm
taxbird-0.7-0.rauch.1.SuSE1000.i686.rpm
xmlsec1-1.2.9-0.rauch.1.i686.rpm
xmlsec1-devel-1.2.9-0.rauch.1.i686.rpm
xmlsec1-nss-1.2.9-0.rauch.1.i686.rpm
xmlsec1-nss-devel-1.2.9-0.rauch.1.i686.rpm
xmlsec1-openssl-1.2.9-0.rauch.1.i686.rpm
xmlsec1-openssl-devel-1.2.9-0.rauch.1.i686.rpm

Now, when I try to run gnucash, I get the message:
%  gnucash
/opt/gnome/share/gnucash/guile-modules/g-wrapped/gw-gnc.scm:37:17: In
procedure dynamic-link in expression (dynamic-link "libgw-gnc"):
/opt/gnome/share/gnucash/guile-modules/g-wrapped/gw-gnc.scm:37:17: file:
"libgw-gnc", message: "libguppitank.so.16: cannot open shared object
file: No such file or directory"
% rpm -q g-wrap slib
g-wrap-1.9.6-0.rauch.3
slib-3a1-46
% locate libguppitank
/opt/opt/gnome/include/gnome-1.0/libguppitank
/opt/opt/gnome/include/gnome-1.0/libguppitank/guppi-object.h
/opt/opt/gnome/include/gnome-1.0/libguppitank/guppi-tank-init.h
/opt/opt/gnome/include/gnome-1.0/libguppitank/guppi-tank.h
/opt/opt/gnome/lib/libguppitank.la
/opt/opt/gnome/lib/libguppitank.so
/opt/opt/gnome/lib/libguppitank.so.16
/opt/opt/gnome/lib/libguppitank.so.16.0.0



_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: can't run gnucash 2.0.1 on SuSE 10.0

Derek Atkins
Hi,

Quoting Steve Kelem <[hidden email]>:

[snip]
>
> Now, when I try to run gnucash, I get the message:
> %  gnucash
> /opt/gnome/share/gnucash/guile-modules/g-wrapped/gw-gnc.scm:37:17: In
> procedure dynamic-link in expression (dynamic-link "libgw-gnc"):
> /opt/gnome/share/gnucash/guile-modules/g-wrapped/gw-gnc.scm:37:17: file:
> "libgw-gnc", message: "libguppitank.so.16: cannot open shared object
> file: No such file or directory"

Um, libguppitank (indeed Guppi at all) is NOT used by gnucash 2.0.
Perhaps you have some remnants of gnucash-1.8 installed?

> % rpm -q g-wrap slib
> g-wrap-1.9.6-0.rauch.3
> slib-3a1-46
> % locate libguppitank
> /opt/opt/gnome/include/gnome-1.0/libguppitank
> /opt/opt/gnome/include/gnome-1.0/libguppitank/guppi-object.h
> /opt/opt/gnome/include/gnome-1.0/libguppitank/guppi-tank-init.h
> /opt/opt/gnome/include/gnome-1.0/libguppitank/guppi-tank.h
> /opt/opt/gnome/lib/libguppitank.la
> /opt/opt/gnome/lib/libguppitank.so
> /opt/opt/gnome/lib/libguppitank.so.16
> /opt/opt/gnome/lib/libguppitank.so.16.0.0

I question why it's in /opt/opt/gnome instead of /opt/gnome.  That
seems... Wrong.. In so many ways.   But as I said earlier, gnucash 2.0
doesn't use guppi, so I suspect you've got a crossover between
gnucash 2.0 and gnucash 1.8.

-derek
--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.