Webkit-gtk version

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Webkit-gtk version

Robert Fewell-2
Just want to clarify what versions of webkit-gtk is now required. My test
VM that has gtk3.10 and webkit2gtk-4.0, version 2.6.6 which does not have
"allow-file-access-from-file-urls", 2.10 has this and so end up with error
in trace file and there is also a critical error when I close gnucash with
a report page open. My other test VM has gtk3.22 and webkit2gtk-4.0,
version 2.16.3 and so I do not see this problem.

I suppose if it tested for version 2.10 and was not found it could fallback
to webkit1gtk which I think is also installed.

Bob
_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Webkit-gtk version

John Ralls-2

> On Jul 16, 2017, at 4:19 AM, Robert Fewell <[hidden email]> wrote:
>
> Just want to clarify what versions of webkit-gtk is now required. My test
> VM that has gtk3.10 and webkit2gtk-4.0, version 2.6.6 which does not have
> "allow-file-access-from-file-urls", 2.10 has this and so end up with error
> in trace file and there is also a critical error when I close gnucash with
> a report page open. My other test VM has gtk3.22 and webkit2gtk-4.0,
> version 2.16.3 and so I do not see this problem.
>
> I suppose if it tested for version 2.10 and was not found it could fallback
> to webkit1gtk which I think is also installed.

Bob,

Fixed and pushed. That property and allow-universal-access-from-file-urls just needed to be version-checked.

Regards,
John Ralls

_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
Loading...