Upgrade, 2.4 to 2.6 creates problems

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade, 2.4 to 2.6 creates problems

Eric Rempel
I have been using Gnucash 2.4 for some 5 years on my Windows 7 system. I'm
very happy with it. Over the weekend I upgraded to 2.6.19. 2.6 would not
open an up-to-date data file, and when I tried to print a report, the
application froze. I have been able to re-install 2.4 and now and
everything is working as before. I'm happy. I would like to upgrade to 2.6
but am now afraid. What did I do wrong?

--
Eric Rempel (204) 326-9621
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade, 2.4 to 2.6 creates problems

John Ralls-2


> On Feb 5, 2018, at 7:31 AM, Eric Rempel <[hidden email]> wrote:
>
> I have been using Gnucash 2.4 for some 5 years on my Windows 7 system. I'm
> very happy with it. Over the weekend I upgraded to 2.6.19. 2.6 would not
> open an up-to-date data file, and when I tried to print a report, the
> application froze. I have been able to re-install 2.4 and now and
> everything is working as before. I'm happy. I would like to upgrade to 2.6
> but am now afraid. What did I do wrong?

While we try to maintain file compatibility through a series we don’t do much in the way of back-testing and some things may drift over the years. I suggest that you upgrade in steps, perhaps 2.6.5-> 2.6.10-> 2.6.15->2.6.19. All of the installers are available on Sourceforge:
https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/ <https://sourceforge.net/projects/gnucash/files/gnucash%20(stable)/>

Regards,
John Ralls



_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade, 2.4 to 2.6 creates problems

Fred Bone
On 5 February 2018 at 7:50, John Ralls said:

>
>
> > On Feb 5, 2018, at 7:31 AM, Eric Rempel <[hidden email]> wrote:
> >
> > I have been using Gnucash 2.4 for some 5 years on my Windows 7 system.
> > I'm very happy with it. Over the weekend I upgraded to 2.6.19. 2.6 would
> > not open an up-to-date data file, and when I tried to print a report,
> > the application froze. I have been able to re-install 2.4 and now and
> > everything is working as before. I'm happy. I would like to upgrade to
> > 2.6 but am now afraid. What did I do wrong?
>
> While we try to maintain file compatibility through a series we don’t do
> much in the way of back-testing and some things may drift over the years.
> I suggest that you upgrade in steps, perhaps 2.6.5-> 2.6.10->
> 2.6.15->2.6.19. All of the installers are available on Sourceforge:
> https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/
> <https://sourceforge.net/projects/gnucash/files/gnucash%20(stable)/>

I am currently using 2.4.12. I have a PortableApps copy of 2.6.17 which
opened my (2.4.12) file just fine last time I tried it.

_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade, 2.4 to 2.6 creates problems

Eric Rempel
I am using 2.4.15. I loaded 2.6.1 and it will not open an up-to-date or
complete file of my data. Fortunately when I go back to 2.4 everything is
fine.

On Mon, Feb 5, 2018 at 11:20 AM, Fred Bone <[hidden email]> wrote:

> On 5 February 2018 at 7:50, John Ralls said:
>
> >
> >
> > > On Feb 5, 2018, at 7:31 AM, Eric Rempel <[hidden email]> wrote:
> > >
> > > I have been using Gnucash 2.4 for some 5 years on my Windows 7 system.
> > > I'm very happy with it. Over the weekend I upgraded to 2.6.19. 2.6
> would
> > > not open an up-to-date data file, and when I tried to print a report,
> > > the application froze. I have been able to re-install 2.4 and now and
> > > everything is working as before. I'm happy. I would like to upgrade to
> > > 2.6 but am now afraid. What did I do wrong?
> >
> > While we try to maintain file compatibility through a series we don’t do
> > much in the way of back-testing and some things may drift over the years.
> > I suggest that you upgrade in steps, perhaps 2.6.5-> 2.6.10->
> > 2.6.15->2.6.19. All of the installers are available on Sourceforge:
> > https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/
> > <https://sourceforge.net/projects/gnucash/files/gnucash%20(stable)/>
>
> I am currently using 2.4.12. I have a PortableApps copy of 2.6.17 which
> opened my (2.4.12) file just fine last time I tried it.
>
>


--
Eric Rempel (204) 326-9621
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade, 2.4 to 2.6 creates problems

David Carlson-4
Eric

It is really taxing my brain to remember the early days of release 2 .6 but
it is a good guess that 2.6.1 was not a good release.

Try going to 2.6.5 as John suggested.

David C



On Feb 6, 2018 9:13 AM, "Eric Rempel" <[hidden email]> wrote:

I am using 2.4.15. I loaded 2.6.1 and it will not open an up-to-date or
complete file of my data. Fortunately when I go back to 2.4 everything is
fine.

On Mon, Feb 5, 2018 at 11:20 AM, Fred Bone <[hidden email]> wrote:

> On 5 February 2018 at 7:50, John Ralls said:
>
> >
> >
> > > On Feb 5, 2018, at 7:31 AM, Eric Rempel <[hidden email]> wrote:
> > >
> > > I have been using Gnucash 2.4 for some 5 years on my Windows 7 system.
> > > I'm very happy with it. Over the weekend I upgraded to 2.6.19. 2.6
> would
> > > not open an up-to-date data file, and when I tried to print a report,
> > > the application froze. I have been able to re-install 2.4 and now and
> > > everything is working as before. I'm happy. I would like to upgrade to
> > > 2.6 but am now afraid. What did I do wrong?
> >
> > While we try to maintain file compatibility through a series we don’t do
> > much in the way of back-testing and some things may drift over the
years.
> > I suggest that you upgrade in steps, perhaps 2.6.5-> 2.6.10->
> > 2.6.15->2.6.19. All of the installers are available on Sourceforge:
> > https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/
> > <https://sourceforge.net/projects/gnucash/files/gnucash%20(stable)/>
>
> I am currently using 2.4.12. I have a PortableApps copy of 2.6.17 which
> opened my (2.4.12) file just fine last time I tried it.
>
>


--
Eric Rempel (204) 326-9621
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/
Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade, 2.4 to 2.6 creates problems

John Ralls-2
Indeed, 2.6.1 had several problems. But it sounds possible that there’s something amiss with your file that 2.4 lets slide while 2.6 chokes. If 2.6.5 won’t load it, open a bug and attach the trace file [1] to it.

Regards,
John Ralls

[1] https://wiki.gnucash.org/wiki/Tracefile <https://wiki.gnucash.org/wiki/Tracefile>


> On Feb 6, 2018, at 7:31 AM, David Carlson <[hidden email]> wrote:
>
> Eric
>
> It is really taxing my brain to remember the early days of release 2 .6 but
> it is a good guess that 2.6.1 was not a good release.
>
> Try going to 2.6.5 as John suggested.
>
> David C
>
>
>
> On Feb 6, 2018 9:13 AM, "Eric Rempel" <[hidden email]> wrote:
>
> I am using 2.4.15. I loaded 2.6.1 and it will not open an up-to-date or
> complete file of my data. Fortunately when I go back to 2.4 everything is
> fine.
>
> On Mon, Feb 5, 2018 at 11:20 AM, Fred Bone <[hidden email]> wrote:
>
>> On 5 February 2018 at 7:50, John Ralls said:
>>
>>>
>>>
>>>> On Feb 5, 2018, at 7:31 AM, Eric Rempel <[hidden email]> wrote:
>>>>
>>>> I have been using Gnucash 2.4 for some 5 years on my Windows 7 system.
>>>> I'm very happy with it. Over the weekend I upgraded to 2.6.19. 2.6
>> would
>>>> not open an up-to-date data file, and when I tried to print a report,
>>>> the application froze. I have been able to re-install 2.4 and now and
>>>> everything is working as before. I'm happy. I would like to upgrade to
>>>> 2.6 but am now afraid. What did I do wrong?
>>>
>>> While we try to maintain file compatibility through a series we don’t do
>>> much in the way of back-testing and some things may drift over the
> years.
>>> I suggest that you upgrade in steps, perhaps 2.6.5-> 2.6.10->
>>> 2.6.15->2.6.19. All of the installers are available on Sourceforge:
>>> https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/
>>> <https://sourceforge.net/projects/gnucash/files/gnucash%20(stable)/>
>>
>> I am currently using 2.4.12. I have a PortableApps copy of 2.6.17 which
>> opened my (2.4.12) file just fine last time I tried it.
>>
>>
>
>
> --
> Eric Rempel (204) 326-9621
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> To update your subscription preferences or to unsubscribe:
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/
> Mailing_Lists for more information.
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> To update your subscription preferences or to unsubscribe:
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.

_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade, 2.4 to 2.6 creates problems

Eric Rempel
In reply to this post by David Carlson-4
I think I've now got it.

When I opened 2.6.5 it automatically opened with a data-set I could not
use. When I clicked on File, and picked one of the suggested files, this
also brought up an outdated data-set. However when I clicked on open and
picked "yesterday's" file, everything worked just fine. All is good. Thank
you.

On Tue, Feb 6, 2018 at 9:31 AM, David Carlson <[hidden email]>
wrote:

> Eric
>
> It is really taxing my brain to remember the early days of release 2 .6
> but it is a good guess that 2.6.1 was not a good release.
>
> Try going to 2.6.5 as John suggested.
>
> David C
>
>
>
> On Feb 6, 2018 9:13 AM, "Eric Rempel" <[hidden email]> wrote:
>
> I am using 2.4.15. I loaded 2.6.1 and it will not open an up-to-date or
> complete file of my data. Fortunately when I go back to 2.4 everything is
> fine.
>
> On Mon, Feb 5, 2018 at 11:20 AM, Fred Bone <[hidden email]>
> wrote:
>
> > On 5 February 2018 at 7:50, John Ralls said:
> >
> > >
> > >
> > > > On Feb 5, 2018, at 7:31 AM, Eric Rempel <[hidden email]> wrote:
> > > >
> > > > I have been using Gnucash 2.4 for some 5 years on my Windows 7
> system.
> > > > I'm very happy with it. Over the weekend I upgraded to 2.6.19. 2.6
> > would
> > > > not open an up-to-date data file, and when I tried to print a report,
> > > > the application froze. I have been able to re-install 2.4 and now and
> > > > everything is working as before. I'm happy. I would like to upgrade
> to
> > > > 2.6 but am now afraid. What did I do wrong?
> > >
> > > While we try to maintain file compatibility through a series we don’t
> do
> > > much in the way of back-testing and some things may drift over the
> years.
> > > I suggest that you upgrade in steps, perhaps 2.6.5-> 2.6.10->
> > > 2.6.15->2.6.19. All of the installers are available on Sourceforge:
> > > https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/
> > > <https://sourceforge.net/projects/gnucash/files/gnucash%20(stable)/>
> >
> > I am currently using 2.4.12. I have a PortableApps copy of 2.6.17 which
> > opened my (2.4.12) file just fine last time I tried it.
> >
> >
>
>
> --
> Eric Rempel (204) 326-9621
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> To update your subscription preferences or to unsubscribe:
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> If you are using Nabble or Gmane, please see
> https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
>
>
>


--
Eric Rempel (204) 326-9621
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.