Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Stefan Norin
I have recently upgraded to OpenSuse 10.2 from 10.1 and decided to upgrade
GnuCash as well. However I ran into a problem I cannot solve.
During ./configure i got this message:

checking for (g-wrap gw-standard) guile module... no
checking for (g-wrap gw standard) guile module... no
configure: WARNING:

    Unable to find the g-wrap standard module, a.k.a. guile-g-wrap.
    You won't be able to run GnuCash without it!

I have both the guile and g-wrap packages installed (including development
packages).

Does anyone know how to solve this??

/Stefan

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Josh Sled
On Sat, 2007-02-10 at 00:13 +0100, stefan wrote:

> I have recently upgraded to OpenSuse 10.2 from 10.1 and decided to upgrade
> GnuCash as well. However I ran into a problem I cannot solve.
> During ./configure i got this message:
>
> checking for (g-wrap gw-standard) guile module... no
> checking for (g-wrap gw standard) guile module... no
> configure: WARNING:
>
>     Unable to find the g-wrap standard module, a.k.a. guile-g-wrap.
>     You won't be able to run GnuCash without it!
>
> I have both the guile and g-wrap packages installed (including development
> packages).
Which versions of them?  And slib, while we're at it?

--
...jsled
http://asynchronous.org/ - a=jsled;b=asynchronous.org;echo ${a}@${b}

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Derek Atkins
In reply to this post by Stefan Norin
Quoting stefan <[hidden email]>:

> I have recently upgraded to OpenSuse 10.2 from 10.1 and decided to upgrade
> GnuCash as well. However I ran into a problem I cannot solve.
> During ./configure i got this message:
>
> checking for (g-wrap gw-standard) guile module... no
> checking for (g-wrap gw standard) guile module... no
> configure: WARNING:
>
>    Unable to find the g-wrap standard module, a.k.a. guile-g-wrap.
>    You won't be able to run GnuCash without it!
>
> I have both the guile and g-wrap packages installed (including development
> packages).
>
> Does anyone know how to solve this??

What version of g-wrap?
What do you get from:

  guile -c "(use-modules (g-wrap gw standard))"

> /Stefan

-derek

--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Maf. King
In reply to this post by Stefan Norin
Hi Stefan,

There is a SuSE 10.2 GC-2.0.4 rpm under the following - any use for you?

ftp://ftp-1.gwdg.de/pub/linux/misc/suser-crauch/10.2/RPMS/

HTH,
Maf.


On Friday 09 Feb 2007, stefan wrote:

> I have recently upgraded to OpenSuse 10.2 from 10.1 and decided to upgrade
> GnuCash as well. However I ran into a problem I cannot solve.
> During ./configure i got this message:
>
> checking for (g-wrap gw-standard) guile module... no
> checking for (g-wrap gw standard) guile module... no
> configure: WARNING:
>
>     Unable to find the g-wrap standard module, a.k.a. guile-g-wrap.
>     You won't be able to run GnuCash without it!
>
> I have both the guile and g-wrap packages installed (including development
> packages).
>
> Does anyone know how to solve this??
>
> /Stefan
>

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Stefan Norin
In reply to this post by Derek Atkins
Saturday 10 February 2007 00:19 skrev Derek Atkins:

> Quoting stefan <[hidden email]>:
> > I have recently upgraded to OpenSuse 10.2 from 10.1 and decided to
> > upgrade GnuCash as well. However I ran into a problem I cannot solve.
> > During ./configure i got this message:
> >
> > checking for (g-wrap gw-standard) guile module... no
> > checking for (g-wrap gw standard) guile module... no
> > configure: WARNING:
> >
> >    Unable to find the g-wrap standard module, a.k.a. guile-g-wrap.
> >    You won't be able to run GnuCash without it!
> >
> > I have both the guile and g-wrap packages installed (including
> > development packages).
> >
> > Does anyone know how to solve this??
>
> What version of g-wrap?
> What do you get from:

>   guile -c "(use-modules (g-wrap gw standard))"
>

I did get: ERROR: In procedure dynamic-link:
ERROR: file: "libgw-guile-standard", message: "libguile.so.12: cannot open
shared object file: No such file or directory"

g-wrap is 1.9.6

/Stefan
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Stefan Norin
In reply to this post by Josh Sled
Saturday 10 February 2007 00:17 skrev Josh Sled:

> On Sat, 2007-02-10 at 00:13 +0100, stefan wrote:
> > I have recently upgraded to OpenSuse 10.2 from 10.1 and decided to
> > upgrade GnuCash as well. However I ran into a problem I cannot solve.
> > During ./configure i got this message:
> >
> > checking for (g-wrap gw-standard) guile module... no
> > checking for (g-wrap gw standard) guile module... no
> > configure: WARNING:
> >
> >     Unable to find the g-wrap standard module, a.k.a. guile-g-wrap.
> >     You won't be able to run GnuCash without it!
> >
> > I have both the guile and g-wrap packages installed (including
> > development packages).
>
> Which versions of them?  And slib, while we're at it?

g-wrap: 1.9.6
guile: 1.8.1
slib: 3a1-79

/Stefan
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Stefan Norin
In reply to this post by Maf. King
Thanks for your suggestion,

I tried that to. Installation was successfull. But it didn' from the menu.
When I tried to run it from the terminal I got this error:
gnucash-bin: error while loading shared libraries: libgailutil.so.17: cannot
open shared object file: No such file or directory

Obviously thre's something wrong with my system, but I cannot figure out how
to proceed. Can anyone provide further help?

/Stefan


Saturday 10 February 2007 00:27 skrev Maf. King:

> Hi Stefan,
>
> There is a SuSE 10.2 GC-2.0.4 rpm under the following - any use for you?
>
> ftp://ftp-1.gwdg.de/pub/linux/misc/suser-crauch/10.2/RPMS/
>
> HTH,
> Maf.
>
> On Friday 09 Feb 2007, stefan wrote:
> > I have recently upgraded to OpenSuse 10.2 from 10.1 and decided to
> > upgrade GnuCash as well. However I ran into a problem I cannot solve.
> > During ./configure i got this message:
> >
> > checking for (g-wrap gw-standard) guile module... no
> > checking for (g-wrap gw standard) guile module... no
> > configure: WARNING:
> >
> >     Unable to find the g-wrap standard module, a.k.a. guile-g-wrap.
> >     You won't be able to run GnuCash without it!
> >
> > I have both the guile and g-wrap packages installed (including
> > development packages).
> >
> > Does anyone know how to solve this??
> >
> > /Stefan
>
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Maf. King
In reply to this post by Stefan Norin
On Friday 09 Feb 2007, you wrote:

> Thanks for your suggestion,
>
> I tried that to. Installation was successfull. But it didn' from the menu.
> When I tried to run it from the terminal I got this error:
> gnucash-bin: error while loading shared libraries: libgailutil.so.17:
> cannot open shared object file: No such file or directory
>
> Obviously thre's something wrong with my system, but I cannot figure out
> how to proceed. Can anyone provide further help?
>
> /Stefan
>

Hi Stefan,

On my 10.1 box, with GC2.0.4 installed and working:

maf@skaro:/opt/gnome/lib>
rpm -q --whatprovides /opt/gnome/lib/libgailutil.so.17

gail-1.8.8-15

Also, you might need to provide the symlink...?

HTH,
Maf.

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Josh Sled
In reply to this post by Stefan Norin
On Sat, 2007-02-10 at 00:37 +0100, stefan wrote:

> > What do you get from:
>
> >   guile -c "(use-modules (g-wrap gw standard))"
> >
>
> I did get: ERROR: In procedure dynamic-link:
> ERROR: file: "libgw-guile-standard", message: "libguile.so.12: cannot open
> shared object file: No such file or directory"
>
> g-wrap is 1.9.6
This looks like guile changed out from underneath a compiled g-wrap...

Did you upgrade guile-1.6 to guile-1.8?

Did you rebuild g-wrap afterwards?

--
...jsled
http://asynchronous.org/ - a=jsled;b=asynchronous.org;echo ${a}@${b}

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Stefan Norin
In reply to this post by Stefan Norin
Saturday 10 February 2007 01:03 skrev du:

> On Friday 09 Feb 2007, you wrote:
> > Thanks for your suggestion,
> >
> > I tried that to. Installation was successfull. But it didn' from the
> > menu. When I tried to run it from the terminal I got this error:
> > gnucash-bin: error while loading shared libraries: libgailutil.so.17:
> > cannot open shared object file: No such file or directory
> >
> > Obviously thre's something wrong with my system, but I cannot figure out
> > how to proceed. Can anyone provide further help?
> >
> > /Stefan
>
> Hi Stefan,
>
> On my 10.1 box, with GC2.0.4 installed and working:
>
> maf@skaro:/opt/gnome/lib>
> rpm -q --whatprovides /opt/gnome/lib/libgailutil.so.17
>
> gail-1.8.8-15
>
>
> HTH,
> Maf.

Hi Maf.

I have gail-1.9.3-17 installed which provides libgailutil.so.18 instead.
Do I have to downgrade??

/Stefan
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Maf. King
On Saturday 10 Feb 2007, stefan wrote:

>
> Hi Maf.
>
> I have gail-1.9.3-17 installed which provides libgailutil.so.18 instead.
> Do I have to downgrade??
>
> /Stefan

Hi Stefan,

Can't answer that :-(

You could try a symlink to link .18 to .17  Might work.  Doubtless, others
will jump in if they know otherwise....

Goodnight,
Maf.



_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Stefan Norin
In reply to this post by Josh Sled
Saturday 10 February 2007 01:11 skrev Josh Sled:

> On Sat, 2007-02-10 at 00:37 +0100, stefan wrote:
> > > What do you get from:
> > >
> > >   guile -c "(use-modules (g-wrap gw standard))"
> >
> > I did get: ERROR: In procedure dynamic-link:
> > ERROR: file: "libgw-guile-standard", message: "libguile.so.12: cannot
> > open shared object file: No such file or directory"
> >
> > g-wrap is 1.9.6
>
> This looks like guile changed out from underneath a compiled g-wrap...
>
> Did you upgrade guile-1.6 to guile-1.8?
>
> Did you rebuild g-wrap afterwards?

Yes during the upgrade guile-1.6 was replaced by 1.8. I suspected this might
had been an issue and removed both the guile and g-wrap packages and
reinstalled them. Unfortunately, I got the same error when I tried to compile
GnuCash again.

/Stefan
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Derek Atkins
In reply to this post by Stefan Norin
Quoting stefan <[hidden email]>:

>>   guile -c "(use-modules (g-wrap gw standard))"
>>
>
> I did get: ERROR: In procedure dynamic-link:
> ERROR: file: "libgw-guile-standard", message: "libguile.so.12: cannot open
> shared object file: No such file or directory"
>
> g-wrap is 1.9.6

This error means that g-wrap was compiled against a different version
of guile than what you have installed.  Uninstall the current version
of g-wrap and reconfigure, rebuild, and reinstall it..  Then rebuild
gnucash.

> /Stefan

-derek

--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Stefan Norin
Thanks Derek,

It worked, but I had to compile g-wrap from source, instead of the package
provided by opensuse 10.2.

Regards

/Stefan


Saturday 10 February 2007 04:17 skrev Derek Atkins:

> Quoting stefan <[hidden email]>:
> >>   guile -c "(use-modules (g-wrap gw standard))"
> >
> > I did get: ERROR: In procedure dynamic-link:
> > ERROR: file: "libgw-guile-standard", message: "libguile.so.12: cannot
> > open shared object file: No such file or directory"
> >
> > g-wrap is 1.9.6
>
> This error means that g-wrap was compiled against a different version
> of guile than what you have installed.  Uninstall the current version
> of g-wrap and reconfigure, rebuild, and reinstall it..  Then rebuild
> gnucash.
>
> > /Stefan
>
> -derek
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Trouble compiling 2.0.4 under OpenSuse 10.2 g-wrap/guile problem

Derek Atkins
Sounds like you need to file a bug report with them!

Luckily GnuCash 2.1/2.2 (and beyond) wont use g-wrap anymore!  Yay!

-derek

Quoting stefan <[hidden email]>:

> Thanks Derek,
>
> It worked, but I had to compile g-wrap from source, instead of the package
> provided by opensuse 10.2.
>
> Regards
>
> /Stefan
>
>
> Saturday 10 February 2007 04:17 skrev Derek Atkins:
>> Quoting stefan <[hidden email]>:
>> >>   guile -c "(use-modules (g-wrap gw standard))"
>> >
>> > I did get: ERROR: In procedure dynamic-link:
>> > ERROR: file: "libgw-guile-standard", message: "libguile.so.12: cannot
>> > open shared object file: No such file or directory"
>> >
>> > g-wrap is 1.9.6
>>
>> This error means that g-wrap was compiled against a different version
>> of guile than what you have installed.  Uninstall the current version
>> of g-wrap and reconfigure, rebuild, and reinstall it..  Then rebuild
>> gnucash.
>>
>> > /Stefan
>>
>> -derek
>



--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.