Security Editor

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Security Editor

Carlos A. Garcia
Dears,

i tried to change to "APHAVANTAGE" in security editor as was indicate:

Using the Security Editor in GnuCash edit every security with Get Online
Quotes enabled that uses a Yahoo! source and either disable Get Online
Quotes or change the the type of quote source to "Unkown" and the source
to "alphavantage"


After change and accept, the Security Editor return to "Currency"

I tried open GNC with sudo and was the same.

Any idea?


_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Security Editor

John Ralls-2


> On Dec 23, 2017, at 11:35 AM, Carlos A. Garcia <[hidden email]> wrote:
>
> Dears,
>
> i tried to change to "APHAVANTAGE" in security editor as was indicate:
>
> Using the Security Editor in GnuCash edit every security with Get Online Quotes enabled that uses a Yahoo! source and either disable Get Online Quotes or change the the type of quote source to "Unkown" and the source to "alphavantage"
>
>
> After change and accept, the Security Editor return to "Currency"
>
> I tried open GNC with sudo and was the same.
>
> Any idea?

The currency backend has already been changed from Yahoo! to Alphavantage so you don't need to change any currencies. You do need to change any non-currency commodities that use any of the Yahoo! variants except Yahoo-JSON.

Regards,
John Ralls


_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Security Editor

Carlos A. Garcia
Dear John,

first of all, have a good 2018.
I installed the same version 2.6.19 in Windows, and as you said, is
automatic. And works perfect.
My problem still in my version 2.6.19 in Linux Mint 18.3 + Cinnamon (and
2.6.12, pre compiled and others versions aI checked)
There are some problem in the interface under Linux.
I don't know if the language problem or other problem.
The versions of the CPAN and F::Q are updated.

I really I don't know how more check and test.

Best Regards



El 23/12/17 a las 18:28, John Ralls escribió:

>
>> On Dec 23, 2017, at 11:35 AM, Carlos A. Garcia <[hidden email]> wrote:
>>
>> Dears,
>>
>> i tried to change to "APHAVANTAGE" in security editor as was indicate:
>>
>> Using the Security Editor in GnuCash edit every security with Get Online Quotes enabled that uses a Yahoo! source and either disable Get Online Quotes or change the the type of quote source to "Unkown" and the source to "alphavantage"
>>
>>
>> After change and accept, the Security Editor return to "Currency"
>>
>> I tried open GNC with sudo and was the same.
>>
>> Any idea?
> The currency backend has already been changed from Yahoo! to Alphavantage so you don't need to change any currencies. You do need to change any non-currency commodities that use any of the Yahoo! variants except Yahoo-JSON.
>
> Regards,
> John Ralls
>
>

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Security Editor

John Ralls-2
Try disabling price retrieval on all but one stock, one that you know is still trading. If price retrieval still fails with just the one then check that you set up your Alphavantage key correctly and that there’s only one instance of F::Q on your system and it’s 1.47.

Once you have price retrieval working with one then you can re-enable the other commodities, perhaps one at a time, to find any that cause a problem.

Regards,
John Ralls

> On Jan 1, 2018, at 1:29 PM, Carlos A. Garcia <[hidden email]> wrote:
>
> Dear John,
>
> first of all, have a good 2018.
> I installed the same version 2.6.19 in Windows, and as you said, is automatic. And works perfect.
> My problem still in my version 2.6.19 in Linux Mint 18.3 + Cinnamon (and 2.6.12, pre compiled and others versions aI checked)
> There are some problem in the interface under Linux.
> I don't know if the language problem or other problem.
> The versions of the CPAN and F::Q are updated.
>
> I really I don't know how more check and test.
>
> Best Regards
>
>
>
> El 23/12/17 a las 18:28, John Ralls escribió:
>>
>>> On Dec 23, 2017, at 11:35 AM, Carlos A. Garcia <[hidden email]> wrote:
>>>
>>> Dears,
>>>
>>> i tried to change to "APHAVANTAGE" in security editor as was indicate:
>>>
>>> Using the Security Editor in GnuCash edit every security with Get Online Quotes enabled that uses a Yahoo! source and either disable Get Online Quotes or change the the type of quote source to "Unkown" and the source to "alphavantage"
>>>
>>>
>>> After change and accept, the Security Editor return to "Currency"
>>>
>>> I tried open GNC with sudo and was the same.
>>>
>>> Any idea?
>> The currency backend has already been changed from Yahoo! to Alphavantage so you don't need to change any currencies. You do need to change any non-currency commodities that use any of the Yahoo! variants except Yahoo-JSON.
>>
>> Regards,
>> John Ralls
>>
>>
>

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Security Editor

David Carlson-4
Carlos,

If you have a lot of securities in your file it might be easier to create a
new test file with just one security present.  It would not even need to be
one you own. :-)

David C

On Jan 1, 2018 10:26 PM, "John Ralls" <[hidden email]> wrote:

> Try disabling price retrieval on all but one stock, one that you know is
> still trading. If price retrieval still fails with just the one then check
> that you set up your Alphavantage key correctly and that there’s only one
> instance of F::Q on your system and it’s 1.47.
>
> Once you have price retrieval working with one then you can re-enable the
> other commodities, perhaps one at a time, to find any that cause a problem.
>
> Regards,
> John Ralls
>
> > On Jan 1, 2018, at 1:29 PM, Carlos A. Garcia <carlos.alberto.garcia.ar@
> gmail.com> wrote:
> >
> > Dear John,
> >
> > first of all, have a good 2018.
> > I installed the same version 2.6.19 in Windows, and as you said, is
> automatic. And works perfect.
> > My problem still in my version 2.6.19 in Linux Mint 18.3 + Cinnamon (and
> 2.6.12, pre compiled and others versions aI checked)
> > There are some problem in the interface under Linux.
> > I don't know if the language problem or other problem.
> > The versions of the CPAN and F::Q are updated.
> >
> > I really I don't know how more check and test.
> >
> > Best Regards
> >
> >
> >
> > El 23/12/17 a las 18:28, John Ralls escribió:
> >>
> >>> On Dec 23, 2017, at 11:35 AM, Carlos A. Garcia <
> [hidden email]> wrote:
> >>>
> >>> Dears,
> >>>
> >>> i tried to change to "APHAVANTAGE" in security editor as was indicate:
> >>>
> >>> Using the Security Editor in GnuCash edit every security with Get
> Online Quotes enabled that uses a Yahoo! source and either disable Get
> Online Quotes or change the the type of quote source to "Unkown" and the
> source to "alphavantage"
> >>>
> >>>
> >>> After change and accept, the Security Editor return to "Currency"
> >>>
> >>> I tried open GNC with sudo and was the same.
> >>>
> >>> Any idea?
> >> The currency backend has already been changed from Yahoo! to
> Alphavantage so you don't need to change any currencies. You do need to
> change any non-currency commodities that use any of the Yahoo! variants
> except Yahoo-JSON.
> >>
> >> Regards,
> >> John Ralls
> >>
> >>
> >
>
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Security Editor

Carlos A. Garcia
   David / John,
   I have just one saving account in U$S. There are not others
   securities/commodities.
   The same file opened in Windows works perfect (with just one currency
   to check/update USD to ARS).
   I checked that Alphavantage key is correct in Linux (in Windows too).
   The F::Q version is updated to 1.47.
   I'm not sure if there are one or more instance of F::Q (in fact, I
   don't know how to check).
   Regards
   Carlos

   El 02/01/18 a las 10:40, David Carlson escribió:

   Carlos,
   If you have a lot of securities in your file it might be easier to
   create a new test file with just one security present.  It would not
   even need to be one you own. :-)
   David C

   On Jan 1, 2018 10:26 PM, "John Ralls" <[1][hidden email]> wrote:

     Try disabling price retrieval on all but one stock, one that you
     know is still trading. If price retrieval still fails with just the
     one then check that you set up your Alphavantage key correctly and
     that there’s only one instance of F::Q on your system and it’s 1.47.
     Once you have price retrieval working with one then you can
     re-enable the other commodities, perhaps one at a time, to find any
     that cause a problem.
     Regards,
     John Ralls
     > On Jan 1, 2018, at 1:29 PM, Carlos A. Garcia
     <[2][hidden email]> wrote:
     >
     > Dear John,
     >
     > first of all, have a good 2018.
     > I installed the same version 2.6.19 in Windows, and as you said,
     is automatic. And works perfect.
     > My problem still in my version 2.6.19 in Linux Mint 18.3 +
     Cinnamon (and 2.6.12, pre compiled and others versions aI checked)
     > There are some problem in the interface under Linux.
     > I don't know if the language problem or other problem.
     > The versions of the CPAN and F::Q are updated.
     >
     > I really I don't know how more check and test.
     >
     > Best Regards
     >
     >
     >
     > El 23/12/17 a las 18:28, John Ralls escribió:
     >>
     >>> On Dec 23, 2017, at 11:35 AM, Carlos A. Garcia
     <[3][hidden email]> wrote:
     >>>
     >>> Dears,
     >>>
     >>> i tried to change to "APHAVANTAGE" in security editor as was
     indicate:
     >>>
     >>> Using the Security Editor in GnuCash edit every security with
     Get Online Quotes enabled that uses a Yahoo! source and either
     disable Get Online Quotes or change the the type of quote source to
     "Unkown" and the source to "alphavantage"
     >>>
     >>>
     >>> After change and accept, the Security Editor return to
     "Currency"
     >>>
     >>> I tried open GNC with sudo and was the same.
     >>>
     >>> Any idea?
     >> The currency backend has already been changed from Yahoo! to
     Alphavantage so you don't need to change any currencies. You do need
     to change any non-currency commodities that use any of the Yahoo!
     variants except Yahoo-JSON.
     >>
     >> Regards,
     >> John Ralls
     >>
     >>
     >
     _______________________________________________
     gnucash-user mailing list
     [4][hidden email]
     [5]https://lists.gnucash.org/mailman/listinfo/gnucash-user
     -----
     Please remember to CC this list on all your replies.
     You can do this by using Reply-To-List or Reply-All.

References

   1. mailto:[hidden email]
   2. mailto:[hidden email]
   3. mailto:[hidden email]
   4. mailto:[hidden email]
   5. https://lists.gnucash.org/mailman/listinfo/gnucash-user
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.