Re: Try rebuilding g-wrap from the SRPM

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Try rebuilding g-wrap from the SRPM

Systems Administrator JIC
Derek, I really did try my best to build g-wrap from a Fedora Core 6 src.rpm (http://rpmseek.com/rpm/g-wrap-1.9.6-7.1.src.html?hl=com&cs=g-wrap:PN:0:0:0:0:3609293), but I just could not get rpmbuild to make that binary.  I finally threw in the towel and asked for help with g-wrap specific to my Centos-5 installation (http://www.centos.org/modules/newbb/viewtopic.php?topic_id=9210&forum=38).

Just like before these .rpms (which supposedly are compiled for my distribution) installed fine. I then ran the gnucash ./configure which seemed to go fine.  When I tried to make, though, I got the very same result (see below) as I did with the other g-wrap-1.9.6-7.1.i386.rpm and g-wrap-devel-1.9.6-7.1.i386.rpm for Fedora Core 6 from http://redhat.csail.mit.edu/pub/fedora/6/i386/os/Fedora/RPMS/.

I am really stumped, Derek.  Do you think there's anything PARTICULARLY unusual about my combination of slib and guile versions which might be causing the g-wrap .rpm not to work with gnucash's make script?

I continue to appreciate whatever attention you can spare.

=================================
[root@netvista gnucash-2.0.5]# rpm -qa | grep g-wrap
g-wrap-devel-1.9.6-13.el5
g-wrap-1.9.6-13.el5
[root@netvista gnucash-2.0.5]# rpm -qa | grep slib
slib-3a3-2
[root@netvista gnucash-2.0.5]# rpm -qa | grep guile
guile-devel-1.8.0-8.20060831cvs
guile-1.8.0-8.20060831cvs
=========================

Clipped from make output: =====================================
Making all in core-utils
make[3]: Entering directory `/usr/src/gnucash-2.0.5/src/core-utils'
FLAVOR=gnome /usr/bin/guile -c \
          "(set! %load-path (cons \"/usr/share/guile/site\" %load-path)) \
           (primitive-load \"./gw-core-utils-spec.scm\") \
           (gw:generate-wrapset \"gw-core-utils\")"
WARNING: (srfi srfi-35): `every' imported from both (oop goops util) and (srfi srfi-1)
WARNING: (srfi srfi-35): `any' imported from both (oop goops util) and (srfi srfi-1)
WARNING: (g-wrap util): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap rti): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap rti): `class-name' imported from both (oop goops) and (g-wrap)
WARNING: (g-wrap c-types): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap c-types): `class-name' imported from both (oop goops) and (g-wrap)
WARNING: (g-wrap enumeration): `class-name' imported from both (oop goops) and (g-wrap)
WARNING: (g-wrap guile): `class-name' imported from both (oop goops) and (g-wrap)
WARNING: (g-wrap compat): `class-name' imported from both (oop goops) and (g-wrap)
WARNING: (g-wrap ws standard): `class-name' imported from both (oop goops) and (g-wrap)
WARNING: (g-wrap guile ws standard): `class-name' imported from both (oop goops) and (g-wrap)
WARNING: (g-wrap gw-glib-spec): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap gw-glib-spec): `class-name' imported from both (oop goops) and (g-wrap)
.
.
.
gw-core-utils.c: In function 'gw_initialize_wrapset_gw_core_utils':
gw-core-utils.c:270: error: too few arguments to function 'gw_wrapset_add_function'
gw-core-utils.c:274: error: too few arguments to function 'gw_wrapset_add_function'
gw-core-utils.c:278: error: too few arguments to function 'gw_wrapset_add_function'
gw-core-utils.c:282: error: too few arguments to function 'gw_wrapset_add_function'
make[4]: *** [gw-core-utils.lo] Error 1
make[4]: Leaving directory `/usr/src/gnucash-2.0.5/src/core-utils'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/usr/src/gnucash-2.0.5/src/core-utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/gnucash-2.0.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gnucash-2.0.5'
make: *** [all] Error 2
====================================================

---- Derek Atkins <[hidden email]> wrote:
> Try rebuilding g-wrap from the SRPM..  It really needs to be built
> specifically against your version of slib and guile.
>
> -derek
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Try rebuilding g-wrap from the SRPM

Derek Atkins
Try the instructions for EPEL:
  http://lists.gnucash.org/pipermail/gnucash-user/2007-June/020775.html

-derek

Quoting Systems Administrator JIC <[hidden email]>:

> Derek, I really did try my best to build g-wrap from a Fedora Core 6
> src.rpm
> (http://rpmseek.com/rpm/g-wrap-1.9.6-7.1.src.html?hl=com&cs=g-wrap:PN:0:0:0:0:3609293), but I just could not get rpmbuild to make that binary.  I finally threw in the towel and asked for help with g-wrap specific to my Centos-5 installation
> (http://www.centos.org/modules/newbb/viewtopic.php?topic_id=9210&forum=38).
>
> Just like before these .rpms (which supposedly are compiled for my
> distribution) installed fine. I then ran the gnucash ./configure
> which seemed to go fine.  When I tried to make, though, I got the
> very same result (see below) as I did with the other
> g-wrap-1.9.6-7.1.i386.rpm and g-wrap-devel-1.9.6-7.1.i386.rpm for
> Fedora Core 6 from
> http://redhat.csail.mit.edu/pub/fedora/6/i386/os/Fedora/RPMS/.
>
> I am really stumped, Derek.  Do you think there's anything
> PARTICULARLY unusual about my combination of slib and guile versions
> which might be causing the g-wrap .rpm not to work with gnucash's
> make script?
>
> I continue to appreciate whatever attention you can spare.
>
> =================================
> [root@netvista gnucash-2.0.5]# rpm -qa | grep g-wrap
> g-wrap-devel-1.9.6-13.el5
> g-wrap-1.9.6-13.el5
> [root@netvista gnucash-2.0.5]# rpm -qa | grep slib
> slib-3a3-2
> [root@netvista gnucash-2.0.5]# rpm -qa | grep guile
> guile-devel-1.8.0-8.20060831cvs
> guile-1.8.0-8.20060831cvs
> =========================
>
> Clipped from make output: =====================================
> Making all in core-utils
> make[3]: Entering directory `/usr/src/gnucash-2.0.5/src/core-utils'
> FLAVOR=gnome /usr/bin/guile -c \
>          "(set! %load-path (cons \"/usr/share/guile/site\" %load-path)) \
>           (primitive-load \"./gw-core-utils-spec.scm\") \
>           (gw:generate-wrapset \"gw-core-utils\")"
> WARNING: (srfi srfi-35): `every' imported from both (oop goops util)
> and (srfi srfi-1)
> WARNING: (srfi srfi-35): `any' imported from both (oop goops util)
> and (srfi srfi-1)
> WARNING: (g-wrap util): imported module (srfi srfi-34) overrides core
> binding `raise'
> WARNING: (g-wrap): imported module (srfi srfi-34) overrides core
> binding `raise'
> WARNING: (g-wrap rti): imported module (srfi srfi-34) overrides core
> binding `raise'
> WARNING: (g-wrap rti): `class-name' imported from both (oop goops)
> and (g-wrap)
> WARNING: (g-wrap c-types): imported module (srfi srfi-34) overrides
> core binding `raise'
> WARNING: (g-wrap c-types): `class-name' imported from both (oop
> goops) and (g-wrap)
> WARNING: (g-wrap enumeration): `class-name' imported from both (oop
> goops) and (g-wrap)
> WARNING: (g-wrap guile): `class-name' imported from both (oop goops)
> and (g-wrap)
> WARNING: (g-wrap compat): `class-name' imported from both (oop goops)
> and (g-wrap)
> WARNING: (g-wrap ws standard): `class-name' imported from both (oop
> goops) and (g-wrap)
> WARNING: (g-wrap guile ws standard): `class-name' imported from both
> (oop goops) and (g-wrap)
> WARNING: (g-wrap gw-glib-spec): imported module (srfi srfi-34)
> overrides core binding `raise'
> WARNING: (g-wrap gw-glib-spec): `class-name' imported from both (oop
> goops) and (g-wrap)
> .
> .
> .
> gw-core-utils.c: In function 'gw_initialize_wrapset_gw_core_utils':
> gw-core-utils.c:270: error: too few arguments to function
> 'gw_wrapset_add_function'
> gw-core-utils.c:274: error: too few arguments to function
> 'gw_wrapset_add_function'
> gw-core-utils.c:278: error: too few arguments to function
> 'gw_wrapset_add_function'
> gw-core-utils.c:282: error: too few arguments to function
> 'gw_wrapset_add_function'
> make[4]: *** [gw-core-utils.lo] Error 1
> make[4]: Leaving directory `/usr/src/gnucash-2.0.5/src/core-utils'
> make[3]: *** [all] Error 2
> make[3]: Leaving directory `/usr/src/gnucash-2.0.5/src/core-utils'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/usr/src/gnucash-2.0.5/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/gnucash-2.0.5'
> make: *** [all] Error 2
> ====================================================
>
> ---- Derek Atkins <[hidden email]> wrote:
>> Try rebuilding g-wrap from the SRPM..  It really needs to be built
>> specifically against your version of slib and guile.
>>
>> -derek
>



--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.