Re: [GNC] [GNC-dev] Debian package

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [GNC] [GNC-dev] Debian package

Stephen M. Butler
Then I promptly hit the Send button without pasting the link for the
debian files.  Must be too early in the morning!

https://drive.google.com/open?id=1VJmtb-Fx00PQna4yQoYm49C88Bi0hneI

--Steve
(or too late in the evening.  I sometimes think they are one and the same!)

On 1/22/19 7:34 AM, Stephen M. Butler wrote:

> On 1/22/19 2:29 AM, Colin Law wrote:
>> Sorry for delay, been otherwise engaged.
>> On a live Ubuntu 18.10 session running off the install image I started
>> by attempting to install gnucash_3.4_amd64.deb
>>
>> ubuntu@ubuntu:~$ sudo dpkg -i Downloads/gnucash_3.4_amd64.deb
>> Selecting previously unselected package gnucash.
>> (Reading database ... 149974 files and directories currently installed.)
>> Preparing to unpack .../gnucash_3.4_amd64.deb ...
>> Unpacking gnucash (1:3.4) ...
>> dpkg: dependency problems prevent configuration of gnucash:
>>  gnucash depends on gnucash-common (= 1:3.4); however:
>>   Package gnucash-common is not installed.
>>  gnucash depends on libaqbanking35-plugins; however:
>>   Package libaqbanking35-plugins is not installed.
>>  gnucash depends on guile-2.2 | guile-2.0; however:
>>   Package guile-2.2 is not installed.
>>   Package guile-2.0 is not installed.
>>  gnucash depends on libfinance-quote-perl; however:
>>   Package libfinance-quote-perl is not installed.
>>  gnucash depends on libhtml-tableextract-perl; however:
>>   Package libhtml-tableextract-perl is not installed.
>>  gnucash depends on libcrypt-ssleay-perl; however:
>>   Package libcrypt-ssleay-perl is not installed.
>>  gnucash depends on libdate-manip-perl; however:
>>   Package libdate-manip-perl is not installed.
>>
>> dpkg: error processing package gnucash (--install):
>>  dependency problems - leaving unconfigured
>> Errors were encountered while processing:
>>  gnucash
>>
>> I then tried gnucash_3.4_amd64.deb
>>
>> ubuntu@ubuntu:~$ sudo dpkg -i Downloads/gnucash-common_3.4_all.deb
>> Selecting previously unselected package gnucash-common.
>> (Reading database ... 149977 files and directories currently installed.)
>> Preparing to unpack .../gnucash-common_3.4_all.deb ...
>> Unpacking gnucash-common (1:3.4) ...
>> dpkg: dependency problems prevent configuration of gnucash-common:
>>  gnucash-common depends on libjs-jquery; however:
>>   Package libjs-jquery is not installed.
>>
>> dpkg: error processing package gnucash-common (--install):
>>  dependency problems - leaving unconfigured
>> Errors were encountered while processing:
>>  gnucash-common
> Thanks Colin.  No worries -- I've busy on other things also.
>
> Looks like the dependency list from the mainline is missing a few
> entries.  I'll check that out.
>
> Also, here are the files for the debian folder used in the build.  Any
> suggestions or corrections would be appreciated.  Wondering if there is
> a way to package this all together instead of having three .deb files?
>
> --Steve
>
>

--
Stephen M Butler, PMP, PSM
[hidden email]
[hidden email]
253-350-0166
-------------------------------------------
GnuPG Fingerprint:  8A25 9726 D439 758D D846 E5D4 282A 5477 0385 81D8

_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.