Problem installing 2.1.5 using MacPorts

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem installing 2.1.5 using MacPorts

John Reynolds-5
I did my best to correctly follow the instructions on the wiki for
installing gnucash-devel on OSX.
http://wiki.gnucash.org/wiki/MacOSX/MacPortsDetail

system is a MacBook Pro 2.4

I installed the latest version of Xcode from apple (v 2.4.1).
I installed the X11 environment from the included disk (apple provided).
Then installed the MacPorts Binary, and ran the self update.

I then issued the command: sudo ports -d install gnucash-devel +guile16

I seemed to complete without problem, but when I ran it, I got this
error:

me$ gnucash &
gnc.bin-Message: main: binreloc relocation support was disable at
configure time.

I then went back to the wiki and did:

sudo port uninstall gnucash-devel
sudo port -f uninstall slib-guile
sudo port -f uninstall guile
sudo port clean slib-guile guile    # for good measure
sudo port -f install guile16
sudo port -f install slib-guile16
sudo port -f install gnucash-devel

I then ran gnucash and got the same error. I executed gnucash from the
X11 environment and got this backtrace:

me$ ./gnucash &
[1] 1971
me$ gnc.bin-Message: main: binreloc relocation support was disable at
configure time.

Backtrace:
In unknown file:
   ?:  0* [primitive-load-path "c-interface.scm"]
In /opt/local/share/gnucash/scm/c-interface.scm:
  21:  1* [require hash-table]
In unknown file:
   ?:  2  (cond ((not feature) (set! *catalog* #f)) ((slib:provided?
   feature)) ...)
   ?:  3  (let* ((path #)) (cond (# #) (# # #) (# # #) ...))
   ?:  4* [catalog:get hash-table]
   ?:  5* (if (not *catalog*) (let* ((slibcat #)) (cond (# # #)) ...))
   ?:  6  (let* ((slibcat #)) (cond (# # #)) (cond (slibcat #)) ...)
   ?:  7  (set! *catalog* (append (catalog:try-read # "usercat")
   *catalog*))
   ?:  8* [append ...
   ?:  9*  [catalog:try-read ...
   ?: 10*   (user-vicinity)

<unnamed port>: In expression (user-vicinity):
<unnamed port>: Unbound variable: user-vicinity

[1]+  Exit 1                  ./gnucash


Any ideas what I am missing or doing wrong? I appreciate the help.

JohnR
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Problem installing 2.1.5 using MacPorts

lingwitt

On 8 Jul 2007, at 8:58:13 AM, John Reynolds wrote:

> I did my best to correctly follow the instructions on the wiki for
> installing gnucash-devel on OSX.
> http://wiki.gnucash.org/wiki/MacOSX/MacPortsDetail

I had similar troubles, but I got it installed as follows:

Remove each of the related packages, as necessary:
(something like)

port uninstall slib-guile
port uninstall slib-guile16
port uninstall slib
port uninstall guile
port uninstall guile16

Then

port install gnucash-devel +guile16

That should do it.

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.