Quantcast

Online quotes

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Online quotes

Kenneth Schneider
OpenSUSE Tumbleweed, lastest
GNUcash 2.6.16
Perl module Perl-Finance-Quote 2.6.16-1.1 is installed.

I'm trying to enable online quotes but I'm unable. In the configuration screen the following error blocks the operation:

Warning: Finance::Quote not installed properly

With error it is not possible to tick the Get online Quotes check box.
Any help appreciated.

Ken Schneider
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Online quotes

Kenneth Schneider
Stated wrong version of perl module correct version is 1.37-3.1

Ken Schneider

> On May 19, 2017, at 3:27 PM, Kenneth Schneider <[hidden email]> wrote:
>
> OpenSUSE Tumbleweed, lastest
> GNUcash 2.6.16
> Perl module Perl-Finance-Quote 2.6.16-1.1 is installed.
>
> I'm trying to enable online quotes but I'm unable. In the configuration screen the following error blocks the operation:
>
> Warning: Finance::Quote not installed properly
>
> With error it is not possible to tick the Get online Quotes check box.
> Any help appreciated.
>
> Ken Schneider
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
>

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Online quotes

N B Day
On Fri, 2017-05-19 at 15:49 -0400, Kenneth Schneider wrote:

> Stated wrong version of perl module correct version is 1.37-3.1
>
> Ken Schneider
>
> > On May 19, 2017, at 3:27 PM, Kenneth Schneider <kschneider@bout-tym
> > e.net> wrote:
> >
> > OpenSUSE Tumbleweed, lastest
> > GNUcash 2.6.16
> > Perl module Perl-Finance-Quote 2.6.16-1.1 is installed.
> >
> > I'm trying to enable online quotes but I'm unable. In the
> > configuration screen the following error blocks the operation:
> >
> > Warning: Finance::Quote not installed properly
> >
> > With error it is not possible to tick the Get online Quotes check
> > box.
> > Any help appreciated.
> >
> >
Ken,

Sorry not to have replied earlier: I was traveling with a hard-to-type-
on tablet.

According to my notes from the last time I fixed Finance::Quote on
Tumbleweed (it has *never* worked with openSUSE out of the box for me):

1. Install perl CPAN: "sudo perl -MCPAN -e shell"

2. Try to install Finance::Quote from the CPAN shell: "install
Finance::Quote"

3. This will probably end in error because some other stuff needs to be
installed first.  You're well experienced and will be able to figure
this out.  I had to install several prerequisits the last time I did
it. CPAN error messages are wordy but will guide you.

4. Test the result with "gnc-fq-dump yahoo CVX" from the command line.
This should fetch the price of a big evil oil company.

I had to go though the same process with this Arch derivative. The
maintainers apparently don't test F::Q.

HTH

--
N. B. Day
39.4042 North, 119.7377 West and 1387 meters up, Temp: 10.6 C (KRNO)
Sun, 2017-05-21 at 06:31 PDT (UTC -0700)
Epicurus up 20 min,  1 user,  load average: 0.03, 0.08, 0.11
Linux 4.10.13-1-ARCH
Antergos Linux release 17.4 (ISO-Rolling), GNOME Shell 3.24.2
This computer in service for 2306 days.
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Online quotes

John Ralls-2

> On May 21, 2017, at 6:35 AM, N B Day <[hidden email]> wrote:
>
> On Fri, 2017-05-19 at 15:49 -0400, Kenneth Schneider wrote:
>> Stated wrong version of perl module correct version is 1.37-3.1
>>
>> Ken Schneider
>>
>>> On May 19, 2017, at 3:27 PM, Kenneth Schneider <kschneider@bout-tym
>>> e.net> wrote:
>>>
>>> OpenSUSE Tumbleweed, lastest
>>> GNUcash 2.6.16
>>> Perl module Perl-Finance-Quote 2.6.16-1.1 is installed.
>>>
>>> I'm trying to enable online quotes but I'm unable. In the
>>> configuration screen the following error blocks the operation:
>>>
>>> Warning: Finance::Quote not installed properly
>>>
>>> With error it is not possible to tick the Get online Quotes check
>>> box.
>>> Any help appreciated.
>>>
>>>
> Ken,
>
> Sorry not to have replied earlier: I was traveling with a hard-to-type-
> on tablet.
>
> According to my notes from the last time I fixed Finance::Quote on
> Tumbleweed (it has *never* worked with openSUSE out of the box for me):
>
> 1. Install perl CPAN: "sudo perl -MCPAN -e shell"
>
> 2. Try to install Finance::Quote from the CPAN shell: "install
> Finance::Quote"
>
> 3. This will probably end in error because some other stuff needs to be
> installed first.  You're well experienced and will be able to figure
> this out.  I had to install several prerequisits the last time I did
> it. CPAN error messages are wordy but will guide you.
>
> 4. Test the result with "gnc-fq-dump yahoo CVX" from the command line.
> This should fetch the price of a big evil oil company.
>
> I had to go though the same process with this Arch derivative. The
> maintainers apparently don't test F::Q.
>

Have you raised a bug with OpenSuse?

Regards,
John Ralls

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Online quotes

Kenneth Schneider
In reply to this post by N B Day
I was going to post my solution last night but it getting well past my bedtime. I found that the package Perl-CGI was not installed. The clue came from running gnc-FAQ-dump that stated the perl package was missing.
Thank you for your response.

Ken Schneider

> On May 21, 2017, at 9:35 AM, N B Day <[hidden email]> wrote:
>
>> On Fri, 2017-05-19 at 15:49 -0400, Kenneth Schneider wrote:
>> Stated wrong version of perl module correct version is 1.37-3.1
>>
>> Ken Schneider
>>
>>> On May 19, 2017, at 3:27 PM, Kenneth Schneider <kschneider@bout-tym
>>> e.net> wrote:
>>>
>>> OpenSUSE Tumbleweed, lastest
>>> GNUcash 2.6.16
>>> Perl module Perl-Finance-Quote 2.6.16-1.1 is installed.
>>>
>>> I'm trying to enable online quotes but I'm unable. In the
>>> configuration screen the following error blocks the operation:
>>>
>>> Warning: Finance::Quote not installed properly
>>>
>>> With error it is not possible to tick the Get online Quotes check
>>> box.
>>> Any help appreciated.
>>>
>>>
> Ken,
>
> Sorry not to have replied earlier: I was traveling with a hard-to-type-
> on tablet.
>
> According to my notes from the last time I fixed Finance::Quote on
> Tumbleweed (it has *never* worked with openSUSE out of the box for me):
>
> 1. Install perl CPAN: "sudo perl -MCPAN -e shell"
>
> 2. Try to install Finance::Quote from the CPAN shell: "install
> Finance::Quote"
>
> 3. This will probably end in error because some other stuff needs to be
> installed first.  You're well experienced and will be able to figure
> this out.  I had to install several prerequisits the last time I did
> it. CPAN error messages are wordy but will guide you.
>
> 4. Test the result with "gnc-fq-dump yahoo CVX" from the command line.
> This should fetch the price of a big evil oil company.
>
> I had to go though the same process with this Arch derivative. The
> maintainers apparently don't test F::Q.
>
> HTH
>
> --
> N. B. Day
> 39.4042 North, 119.7377 West and 1387 meters up, Temp: 10.6 C (KRNO)
> Sun, 2017-05-21 at 06:31 PDT (UTC -0700)
> Epicurus up 20 min,  1 user,  load average: 0.03, 0.08, 0.11
> Linux 4.10.13-1-ARCH
> Antergos Linux release 17.4 (ISO-Rolling), GNOME Shell 3.24.2
> This computer in service for 2306 days.
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
>

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Loading...