Help installing gnucash-2.0.1 on a Zenwalk machine

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Help installing gnucash-2.0.1 on a Zenwalk machine

Bobby Goins
I am trying to install gnucash-2.0.1 on my machine running Zenwalk 2.8.  
Since I don't have a full gnome environment, I have installed the
following dependencies:

libofx-0.8.0
guile-1.8.0
g-wrap-1.9.6
slib-3a3-2
gwenhywfar-2.4.0

I tried to configure aqbanking-2.2.0, but I get the following:

    .
    .
    .
    configure: WARNING:
     QT3 is not explicitly disabled and I could not find some QT3 components
     (see which are missing in messages above).
     If you don't want to compile QT3 applications please use
    "--disable-qt3".

    checking if qt3 version is fully useable... no
    checking target system type... posix
    checking for xgettext... xgettext
    checking for locale.h... (cached) yes
    checking libintl.h usability... yes
    checking libintl.h presence... yes
    checking for libintl.h... yes
    checking for library containing gettext... none required
    checking for msgfmt... /usr/bin/msgfmt
    checking whether msgfmt understands --qt... yes
    checking whether this is an official release... no
    checking for compiler arguments... -g -O2 -g -Wall
    -Wdeclaration-after-statement
    checking if symbol visibility is supported... no (needs gcc >=4.0,
    you have 3.4.6)
    checking docpath... /root/apidoc
    checking if full docu should be created... no
    checking doxygen tag files... none
    checking whether local install mode is wanted... no
    configure: *** Libchipcard2-client is required for backend
    "AqGeldKarte". Specify --with-backends="aqhbci aqdtaus aqofxconnect"
    to build aqbanking without that backend.
    configure: *** LibOFX>=0.8.0 is required for backend "aqofxconnect".
    Specify --with-backends="aqhbci aqdtaus aqgeldkarte" to build
    aqbanking without that backend.
    configure: *** QT3 is required for QT-frontend "qbanking". Specify
    --with-frontends="cbanking g2banking" to build aqbanking without
    that frontend.
    configure: *** KDE3 is required for KDE-frontend "kbanking". Specify
    --with-frontends="cbanking g2banking qbanking" to build aqbanking
    without that frontend.
    configure: error: *** Requirements not fulfilled. Fix your
    requirements or change the configuration.

As you can tell from above, I have installed libofx-0.8.0.  Here is
where it is located on my machine:

    /usr/lib/libofx.so
    /usr/lib/libofx.la
    /usr/lib/libofx.a
    /usr/lib/libofx.so.2.0.0
    /usr/lib/libofx.so.2

_Do I really need Libchipcard2-client, QT3 and KDE3 ?_


Also, I tried to compile gnucash-2.0.1 without aqbanking and here is
what I got:

    .
    .
    .
    checking for guile - 1.8.0 <= version < 99.99.99... yes: 1.8.0
    checking for g-wrap-config... /usr/local/bin/g-wrap-config
    checking for g-wrap - version >= 1.3.3... yes
    checking for g-wrap compile args... Package g-wrap-2.0-guile was not
    found in the pkg-config search path.
    Perhaps you should add the directory containing `g-wrap-2.0-guile.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'g-wrap-2.0-guile' found

    checking for g-wrap link args... Package g-wrap-2.0-guile was not
    found in the pkg-config search path.
    Perhaps you should add the directory containing `g-wrap-2.0-guile.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'g-wrap-2.0-guile' found

    checking for g-wrap module directory...
    checking g-wrap-wct.h usability... yes
    checking g-wrap-wct.h presence... yes
    checking for g-wrap-wct.h... yes
    checking for (g-wrap) guile module... yes
    checking for (g-wrap gw-glib-spec) guile module... yes
    checking for SLIB support... configure: error:

       Cannot find SLIB.  Are you sure you have it installed?
       See http://bugzilla.gnome.org/show_bug.cgi?id=347922

Here is where g-wrap-2.0-guile.pc is at on my machine:

    /usr/local/lib/pkgconfig/g-wrap-2.0-guile.pc
    /usr/local/g-wrap-1.9.6/guile/g-wrap-2.0-guile.pc

As you see at the top, I have installed slib-3a3-2.  There are many
files, I don't know which one it is looking for.

_Does anyone have any suggestions to get gnucash up and running under
Zenwalk?_

I really need gnucash working so I can enter the last 2 months of data.  
(I have almost 22 years of data entered using pre-2.0 gnucash.)

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Help installing gnucash-2.0.1 on a Zenwalk machine

Josh Sled
On Wed, 2006-08-30 at 22:24 -0400, Bobby Goins wrote:

> I tried to configure aqbanking-2.2.0, but I get the following:
[deletia]
> _Do I really need Libchipcard2-client, QT3 and KDE3 ?_

I'm no expert on this, but it seems like you need those libraries if you
want the functionality they enable.  In particular:

- libchipcard: for chip-card based transactions (German HBCI
transactions, from what I can tell...)
- qt3, kde: the qbanking and kbanking frontends, respectively

Though, I'm just closely reading what the error messages say...


As for libofx-0.8.0, the output you pasted indicates that the configure
script can't find libofx-0.8.0.  Is there some "-devel" package you need
to install?  You might check the output of config.log to see how it's
trying (failing) to check for libofx.


> Also, I tried to compile gnucash-2.0.1 without aqbanking and here is
> what I got:
>     checking for guile - 1.8.0 <= version < 99.99.99... yes: 1.8.0

IIRC there are ... issues ... using guile 1.8.0.  You might want to
check the mailing list archives, here.


>     checking for g-wrap-config... /usr/local/bin/g-wrap-config
>     checking for g-wrap - version >= 1.3.3... yes
>     checking for g-wrap compile args... Package g-wrap-2.0-guile was not
>     found in the pkg-config search path.
>     Perhaps you should add the directory containing `g-wrap-2.0-guile.pc'
>     to the PKG_CONFIG_PATH environment variable
>     No package 'g-wrap-2.0-guile' found
[...]
> Here is where g-wrap-2.0-guile.pc is at on my machine:
>
>     /usr/local/lib/pkgconfig/g-wrap-2.0-guile.pc
>     /usr/local/g-wrap-1.9.6/guile/g-wrap-2.0-guile.pc

Um.... is `/usr/local/lib/pkgconfig` in PKG_CONFIG_PATH ?

(Why is g-wrap installed into /usr/local?)


>     checking for SLIB support... configure: error:
>
>        Cannot find SLIB.  Are you sure you have it installed?
>        See http://bugzilla.gnome.org/show_bug.cgi?id=347922
[deletia]
> As you see at the top, I have installed slib-3a3-2.  There are many
> files, I don't know which one it is looking for.

Did you check the bug?  Does it apply?

Is there anything interesting in config.log for that check?

If not, what's the output when you run the relevant commands from
configure.in by hand?

--
...jsled
http://asynchronous.org/ - `a=jsled; b=asynchronous.org; echo ${a}@${b}`

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.

signature.asc (196 bytes) Download Attachment