Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Robert Heller
Have RPMs for RHEL 4/CentOS 4.3 been created for Gnucash 2.0 yet?  Just
checking at this point -- I *still* have not upgraded my system (yes, it
is *still* running RH 7.3, so I am still using GnuCash 1.8.10).

--
Robert Heller             -- 978-544-6933
Deepwoods Software        -- Linux Installation and Administration
http://www.deepsoft.com/  -- Web Hosting, with CGI and Database
[hidden email]       -- Contract Programming: C/C++, Tcl/Tk
                                                                                       
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Robert Heller                      -- 978-544-6933
Deepwoods Software        -- Download the Model Railroad System
http://www.deepsoft.com/  -- Binaries for Linux and MS-Windows
heller@deepsoft.com        -- http://www.deepsoft.com/ModelRailroadSystem/
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Derek Atkins
Robert Heller <[hidden email]> writes:

> Have RPMs for RHEL 4/CentOS 4.3 been created for Gnucash 2.0 yet?  Just
> checking at this point -- I *still* have not upgraded my system (yes, it
> is *still* running RH 7.3, so I am still using GnuCash 1.8.10).

Maybe Bill Nottingham will build them?  GnuCash 2.0's dependencies
were designed to allow it to build on RHEL4.

-derek
--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Bill Nottingham
In reply to this post by Robert Heller
Robert Heller ([hidden email]) said:
> Have RPMs for RHEL 4/CentOS 4.3 been created for Gnucash 2.0 yet?  Just
> checking at this point -- I *still* have not upgraded my system (yes, it
> is *still* running RH 7.3, so I am still using GnuCash 1.8.10).

I intend to put some up at some point at

http://people.redhat.com/notting/gnucash/

but haven't gotten around to it yet.

Bill
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Robert Heller
At Tue, 11 Jul 2006 15:29:20 -0400 Bill Nottingham <[hidden email]> wrote:

>
> Robert Heller ([hidden email]) said:
> > Have RPMs for RHEL 4/CentOS 4.3 been created for Gnucash 2.0 yet?  Just
> > checking at this point -- I *still* have not upgraded my system (yes, it
> > is *still* running RH 7.3, so I am still using GnuCash 1.8.10).
>
> I intend to put some up at some point at
>
> http://people.redhat.com/notting/gnucash/
>
> but haven't gotten around to it yet.

I started to try to build it on my CentOS 4.3 box, but found a
dependency problem: g-wrap.  I was in the process of downloading the FC4
RPM(s) for g-wrap from rpmfind.net (could not find RHel 4/CentOS 4 rpms
for g-wrap), when I lost power -- a tornado seems to have gone through
'downtown' Wendell, MA Tuesday afternoon - :-(.  We only just got power back
a little over an hour ago.

>
> Bill
>
>      

--
Robert Heller             -- 978-544-6933
Deepwoods Software        -- Linux Installation and Administration
http://www.deepsoft.com/  -- Web Hosting, with CGI and Database
[hidden email]       -- Contract Programming: C/C++, Tcl/Tk
                                                                                   
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Robert Heller                      -- 978-544-6933
Deepwoods Software        -- Download the Model Railroad System
http://www.deepsoft.com/  -- Binaries for Linux and MS-Windows
heller@deepsoft.com        -- http://www.deepsoft.com/ModelRailroadSystem/
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Robert Heller
At Fri, 11 Aug 2006 23:55:26 -0700 Steve Calabrese <[hidden email]> wrote:

>
> I had gnucash 1.8 running on CentOS 4.2, looking forward to trying v2 on
> CentOS 4.3.

You should be sending this to the gnucash list. *I'm* not about to build
*official* Gnucash RPMs, although I might hack what I have and create a
set of 'unofficial' RPMs for my own use.

>
>                                                          

--
Robert Heller             -- 978-544-6933
Deepwoods Software        -- Linux Installation and Administration
http://www.deepsoft.com/  -- Web Hosting, with CGI and Database
[hidden email]       -- Contract Programming: C/C++, Tcl/Tk
                               
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Robert Heller                      -- 978-544-6933
Deepwoods Software        -- Download the Model Railroad System
http://www.deepsoft.com/  -- Binaries for Linux and MS-Windows
heller@deepsoft.com        -- http://www.deepsoft.com/ModelRailroadSystem/
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Derek Atkins
Robert Heller <[hidden email]> writes:

> At Fri, 11 Aug 2006 23:55:26 -0700 Steve Calabrese <[hidden email]> wrote:
>
>>
>> I had gnucash 1.8 running on CentOS 4.2, looking forward to trying v2 on
>> CentOS 4.3.
>
> You should be sending this to the gnucash list. *I'm* not about to build
> *official* Gnucash RPMs, although I might hack what I have and create a
> set of 'unofficial' RPMs for my own use.

Try http://people.redhat.com/notting/gnucash/

-derek
--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Robert Heller
At Sat, 12 Aug 2006 15:46:34 -0400 Derek Atkins <[hidden email]> wrote:

>
> Robert Heller <[hidden email]> writes:
>
> > At Fri, 11 Aug 2006 23:55:26 -0700 Steve Calabrese <[hidden email]> wrote:
> >
> >>
> >> I had gnucash 1.8 running on CentOS 4.2, looking forward to trying v2 on
> >> CentOS 4.3.
> >
> > You should be sending this to the gnucash list. *I'm* not about to build
> > *official* Gnucash RPMs, although I might hack what I have and create a
> > set of 'unofficial' RPMs for my own use.
>
> Try http://people.redhat.com/notting/gnucash/

Nothing newer for RHEL 4 than the 1.8.12 release.  There is a FC5 RPM
for 2.0.0 release, but I don't think that will install on RHEL 4 and
don't know if the SRPM will build either.

I was able to build 2.0.0 from the tarball on a CentOS 4.3, after
installing g-wrap 1.3.4 and g-wrap-devel 1.3.4 (both from FC4 I think),
but the spec file in the 2.0.0 tarball is broken WRT a non FC distro.
I guess making a small ('brute force') hack to the spec file will get
me a set of RPMs *I* could install.  I am not enough of a spec file
hacker to do this with the finese to make the RPMs universally useful
(and I don't know if the g-wrap RPMs I installed are the ones that make
the most sense under RHel 4 -- I just picked something conservitive and
that rpm did not bitch about with -hiv --test). I understand that Bill
Nottingham did a test build of a set of RPMs but there was some problem
("failed the smoke-test").  I've not even bothered to download the 2.0.1
tarball -- I figure that sooner or latter a set of 2.0.1 RPMs for RHEL 4
will show up "Real Soon Now".

Although I was able to build and install (under /usr/local/...) 2.0.0
on a developmental CentOS 4.3 system, I'm still using 1.8.12 release
(installed from the 1.8.12-0.rhel4 rpms downloaded from
http://people.redhat.com/notting/gnucash/RHEL-4/i386/) on my production
system (now (finally) upgraded from RH 7.3 to CentOS 4.3).

>
> -derek

--
Robert Heller             -- 978-544-6933
Deepwoods Software        -- Linux Installation and Administration
http://www.deepsoft.com/  -- Web Hosting, with CGI and Database
[hidden email]       -- Contract Programming: C/C++, Tcl/Tk
                           
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Robert Heller                      -- 978-544-6933
Deepwoods Software        -- Download the Model Railroad System
http://www.deepsoft.com/  -- Binaries for Linux and MS-Windows
heller@deepsoft.com        -- http://www.deepsoft.com/ModelRailroadSystem/
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Derek Atkins
Robert Heller <[hidden email]> writes:

> At Sat, 12 Aug 2006 15:46:34 -0400 Derek Atkins <[hidden email]> wrote:
>
>>
>> Robert Heller <[hidden email]> writes:
>>
>> > At Fri, 11 Aug 2006 23:55:26 -0700 Steve Calabrese <[hidden email]> wrote:
>> >
>> >>
>> >> I had gnucash 1.8 running on CentOS 4.2, looking forward to trying v2 on
>> >> CentOS 4.3.
>> >
>> > You should be sending this to the gnucash list. *I'm* not about to build
>> > *official* Gnucash RPMs, although I might hack what I have and create a
>> > set of 'unofficial' RPMs for my own use.
>>
>> Try http://people.redhat.com/notting/gnucash/
>
> Nothing newer for RHEL 4 than the 1.8.12 release.  There is a FC5 RPM
> for 2.0.0 release, but I don't think that will install on RHEL 4 and
> don't know if the SRPM will build either.

I don't see why the SRPM wouldn't build...

> I was able to build 2.0.0 from the tarball on a CentOS 4.3, after
> installing g-wrap 1.3.4 and g-wrap-devel 1.3.4 (both from FC4 I think),
> but the spec file in the 2.0.0 tarball is broken WRT a non FC distro.
> I guess making a small ('brute force') hack to the spec file will get
> me a set of RPMs *I* could install.  I am not enough of a spec file

Yeah, the "problem" is that the RPM is looking for the fedora-release
RPM in order to determine the actual release number to put into the
package.  Arguably this should just be removed (or made optional).

> Although I was able to build and install (under /usr/local/...) 2.0.0
> on a developmental CentOS 4.3 system, I'm still using 1.8.12 release
> (installed from the 1.8.12-0.rhel4 rpms downloaded from
> http://people.redhat.com/notting/gnucash/RHEL-4/i386/) on my production
> system (now (finally) upgraded from RH 7.3 to CentOS 4.3).

Well, the code was designed to build on RHEL4, so I'm not at all
surprised that you can build it.  I'd have been extremely shocked
if you couldn't.

I do hope that Bill will decide to build RPMS for EL4 at some point.

-derek

--
       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       [hidden email]                        PGP key available
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Bill Nottingham
Derek Atkins ([hidden email]) said:
> I do hope that Bill will decide to build RPMS for EL4 at some point.

I'll have them up as soon as I figure out which of gnucash, guile,
g-wrap, or 'other' is causing it to segfault on start on x86_64. :)

Bill
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Robert Heller
At Mon, 14 Aug 2006 10:32:53 -0400 Bill Nottingham <[hidden email]> wrote:

>
> Derek Atkins ([hidden email]) said:
> > I do hope that Bill will decide to build RPMS for EL4 at some point.
>
> I'll have them up as soon as I figure out which of gnucash, guile,
> g-wrap, or 'other' is causing it to segfault on start on x86_64. :)

I was able to build a *working* *32-bit* version from the tarball for
2.0.0 -- I just needed to install g-wrap-devel, I think from FC 3 or FC
4 -- g-wrap(-devel) is not part of the CentOS 4.3 distro (and I guess
not part of the RHEL 4 distro either). It might be that something is not
64-bit clean?

>
> Bill
>
>                                                

--
Robert Heller             -- 978-544-6933
Deepwoods Software        -- Linux Installation and Administration
http://www.deepsoft.com/  -- Web Hosting, with CGI and Database
[hidden email]       -- Contract Programming: C/C++, Tcl/Tk
                                                             
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Robert Heller                      -- 978-544-6933
Deepwoods Software        -- Download the Model Railroad System
http://www.deepsoft.com/  -- Binaries for Linux and MS-Windows
heller@deepsoft.com        -- http://www.deepsoft.com/ModelRailroadSystem/
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Brian-7
In reply to this post by Bill Nottingham
On Mon, Aug 14, 2006 at 10:32:53AM -0400, Bill Nottingham wrote:
> Derek Atkins ([hidden email]) said:
> > I do hope that Bill will decide to build RPMS for EL4 at some point.
>
> I'll have them up as soon as I figure out which of gnucash, guile,
> g-wrap, or 'other' is causing it to segfault on start on x86_64. :)
>
> Bill

Not sure if this is related but I get frequent errors on this AMD64 machine as
per below.
Using Gnucash 2.0 compiled from sources.
Brian

Aug 15 08:10:47 novell kernel: gs[18048]: segfault at 0000000000000008 rip
0000000000605c54 rsp 00007fffff852d00 error 4
Aug 15 08:10:49 novell kernel: gs[18056]: segfault at 0000000000000008 rip
0000000000605c54 rsp 00007fffffe539b0 error 4

> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
>

--
Powered by Suse Linux 9.2

_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: Gnucash 2.0 RPMS for RHEL 4/CentOS 4.3?

Bill Nottingham
In reply to this post by Robert Heller
Robert Heller ([hidden email]) said:

> > Derek Atkins ([hidden email]) said:
> > > I do hope that Bill will decide to build RPMS for EL4 at some point.
> >
> > I'll have them up as soon as I figure out which of gnucash, guile,
> > g-wrap, or 'other' is causing it to segfault on start on x86_64. :)
>
> I was able to build a *working* *32-bit* version from the tarball for
> 2.0.0 -- I just needed to install g-wrap-devel, I think from FC 3 or FC
> 4 -- g-wrap(-devel) is not part of the CentOS 4.3 distro (and I guess
> not part of the RHEL 4 distro either). It might be that something is not
> 64-bit clean?

Found it... something deep inside guile that was fixed between 1.6.4
and 1.6.7. RPMs up now.

Bill
_______________________________________________
gnucash-user mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-user
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.