[GNC] gnucash 3.2 failes to open database in Postgresql 10

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GNC] gnucash 3.2 failes to open database in Postgresql 10

Deamen TANG
Hi There,

I am using gnucash 3.2 with Postgresql 10,  after I have created my account
in gnucash I can successfully save it into postgres, but after I close
gnucash and open the account again, I get an error saying "experienced an
error or encountered bad or corrupt data".

I checked the postgres log, it was complaining about relation "gnclock"
already exists:
2018-07-02 09:33:30.982 AEST [30291] ERROR:  relation "gnclock" already
exists
2018-07-02 09:33:30.982 AEST [30291] STATEMENT:  CREATE TABLE gnclock (
Hostname varchar(255), PID int )

If I go to delete the "gnclock" table, I am able to open my account, but if
I close gnucash again I get the same error when I re-open my account.

For now, I have to drop the "gnclock" table after I close gnucash.

Could anyone please advise if this is a bug or a user error?

I tried the official windows binary and compiled one under Fedora 26, I am
getting the same error.

Thanks

Song
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.