[GNC-dev] GnuCash V3.3

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[GNC-dev] GnuCash V3.3

David Cousens
Just downloaded the tarball and built V3.3  The initial splash scrren is
still displaying V3.2, a fairly minor point.
More significantly I was importing an OFX file and the main matcher dialog
will not allow any selection of transactions for assignment of a destination
account https://bugs.gnucash.org/show_bug.cgi?id=796872 raised.

David



-----
David Cousens
--
Sent from: http://gnucash.1415818.n4.nabble.com/GnuCash-Dev-f1435356.html
_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
David Cousens
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] GnuCash V3.3

John Ralls-2


> On Sep 30, 2018, at 5:34 PM, David Cousens <[hidden email]> wrote:
>
> Just downloaded the tarball and built V3.3  The initial splash scrren is
> still displaying V3.2, a fairly minor point.
> More significantly I was importing an OFX file and the main matcher dialog
> will not allow any selection of transactions for assignment of a destination
> account https://bugs.gnucash.org/show_bug.cgi?id=796872 raised.

David,

I just tested with the MacOS bundle--built from the 3.3 tarball--and I see GnuCash 3.3+(2018-09-29) in both the splash screen and the About GnuCash dialog. I tested importing an OFX file and the matcher at least went through the motions of selecting an account for an unmatched account.

When you built GnuCash did you uninstall the previous build and start from a clean build directory?

Regards,
John Ralls

_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] GnuCash V3.3

David Cousens
John,
My bad. I did uninstall the  previous version but I also had a V3.2 built
locally in $HOME/.local and I had prepended
that directory to the $PATH so it was being picked up first. I have fixed
that and am now getting V3.3 on the initial
splash screen and in the help->About.  The problem with the OFX file
importing however still remains. I also have a
build from the master from a week or two ago( V3.2) which is working fine
with the OFX importing. I can rebuild that
from both the master and maint branches and see if I can track down the
problem.

David




-----
David Cousens
--
Sent from: http://gnucash.1415818.n4.nabble.com/GnuCash-Dev-f1435356.html
_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
David Cousens
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] GnuCash V3.3

David Cousens
In reply to this post by John Ralls-2
John,

 I fetched GnuCash/gnucash from GitHub, then built the master and it works
fine. Checked out maint and built it and it
is failing to allow selection. I did a diff on the two versions of
import-main-matcher.c and as far as I can see the
only differences are the changes intoduced with the patch for 796778 to put
multiple selection into the matcher and
these are working OK.
I then setup a Bug796872 branch on maint and copied the
import-main-matcher.c and dialog-import.glade from the master
branch into maint then rebuilt maint and it works fine. I have pushed that
Bug796872 branch to my PR and created a pull
request to the GitHub Gnucash repository for it. If you want to use it, it
will also incorporate the fixes from
Bug796778 for multiple selection and assignment of the destination account
to the selection in the import matcher.

Cheers

David Cousens



-----
David Cousens
--
Sent from: http://gnucash.1415818.n4.nabble.com/GnuCash-Dev-f1435356.html
_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
David Cousens
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] GnuCash V3.3

Geert Janssens-4
David,

It's not really clear to me from your descriptions whether the problem you experience now in
gnucash 3.3 is new. Did the same issue exist in gnucash 3.2 (previous release) ?

If so it would be very useful for further debugging if you could point at the exact commit where
it starts failing. You can use git bisect to find this.

You also refer to your patches for multiple selection. These were merged into the master
branch, so they should only appear in gnucash 4.x. Were you expecting to see them in 3.3 ?

Geert

Op maandag 1 oktober 2018 10:38:55 CEST schreef David Cousens:

> John,
>
>  I fetched GnuCash/gnucash from GitHub, then built the master and it works
> fine. Checked out maint and built it and it
> is failing to allow selection. I did a diff on the two versions of
> import-main-matcher.c and as far as I can see the
> only differences are the changes intoduced with the patch for 796778 to put
> multiple selection into the matcher and
> these are working OK.
> I then setup a Bug796872 branch on maint and copied the
> import-main-matcher.c and dialog-import.glade from the master
> branch into maint then rebuilt maint and it works fine. I have pushed that
> Bug796872 branch to my PR and created a pull
> request to the GitHub Gnucash repository for it. If you want to use it, it
> will also incorporate the fixes from
> Bug796778 for multiple selection and assignment of the destination account
> to the selection in the import matcher.
>
> Cheers
>
> David Cousens
>
>
>
> -----
> David Cousens
> --
> Sent from: http://gnucash.1415818.n4.nabble.com/GnuCash-Dev-f1435356.html
> _______________________________________________
> gnucash-devel mailing list
> [hidden email]
> https://lists.gnucash.org/mailman/listinfo/gnucash-devel


_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] GnuCash V3.3

David Cousens
Geert,

I had used V3.1, I think to do my tax the first week in August and because I
had to import a lot of data I started thinking about speeding that up with
the multiple selection. I downloaded V3.2  but didn't really use it before I
patched  the unpacked files when I had the multiple selection changes
working, so I don't think I used V3.2 in it's original form.  I still have
the zipped tarball for V3.2 I downloaded on 9th August. I'll unpack the
tarball again and rebuild it and let you know.

OK I've just rebuilt V3.2 Build ID: 3.2+ (2018-06-24) from the zipped
tarball downloaded on the 9th August and it also has the same problem as
V3.3. The import matcher dialog comes up with all the transactions in yellow
with A checked (I'm importing into a new blank set of books). I am unable to
even select single rows and select and apply a destination account to them.
It looks like that problem carried through from V3.2

As far as I know the import OFX was working in V3.1 as I used it extensively
while doing my tax in the first week of August. I no longer have the tarball
for that.  It's 1:00 am here so I will try and locate where the importer
stopped working tomorrow morning and which commit produced the change and
get back to you
 
I was only referring to the patches because by using the patch files in V3.3
instead of the original files, importing the OFX files is working OK. I did
a diff on import-main-matcher.c from the patch and from the V3.3 tarball but
the only differences I could see were the changes to put the multiple
selection in.

No I was expecting that patch to go into V4 not V3.3 as I had branched that
off the master branch as it was a new feature. If anyone seriously wants it
before then They should be able to pull the files to patch it from the
Bug796778 commit to the master. For my own use I can patch it.

David Cousens





-----
David Cousens
--
Sent from: http://gnucash.1415818.n4.nabble.com/GnuCash-Dev-f1435356.html
_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
David Cousens
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] GnuCash V3.3

David Cousens
In reply to this post by Geert Janssens-4
Geert,

My apologies V3,1 ,V3.2 and V3.3 are behaving as expected and as they should
with OFX importing and are correctly importing the data file in all three
versions. It was just finger trouble on my part. Managed to confuse myself
totally by having V3.2 installed in both /usr/local and $HOME/.local with
the latter first up in the path variable. I usually have the stable version
installed in /usr/local for production use and don't have anything installed
in $HOME/.local but while rewriting the wiki I installed it there to make
sure I had the instructions right so it was coming up instead of V3.3 in
/usr/local. After that the confusion just compounded. This morning I cleared
all the installations out, reinstalled them one by one and checked out the
importing of OFX in each and it was fine.

David



-----
David Cousens
--
Sent from: http://gnucash.1415818.n4.nabble.com/GnuCash-Dev-f1435356.html
_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
David Cousens
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] GnuCash V3.3

Geert Janssens-4
Op dinsdag 2 oktober 2018 05:36:08 CEST schreef David Cousens:

> Geert,
>
> My apologies V3,1 ,V3.2 and V3.3 are behaving as expected and as they should
> with OFX importing and are correctly importing the data file in all three
> versions. It was just finger trouble on my part. Managed to confuse myself
> totally by having V3.2 installed in both /usr/local and $HOME/.local with
> the latter first up in the path variable. I usually have the stable version
> installed in /usr/local for production use and don't have anything
> installed in $HOME/.local but while rewriting the wiki I installed it there
> to make sure I had the instructions right so it was coming up instead of
> V3.3 in /usr/local. After that the confusion just compounded. This morning
> I cleared all the installations out, reinstalled them one by one and
> checked out the importing of OFX in each and it was fine.
>
> David

Phew, good to hear that.

Geert


_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel