[GNC-dev] Compatibility Question

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[GNC-dev] Compatibility Question

GnuCash - Dev mailing list
Hello,

I am looking at https://wiki.gnucash.org/wiki/FAQ#Q:_Can_I_exchange_Gnucash_file_with_any_other_version_of_GnuCash.3F <https://wiki.gnucash.org/wiki/FAQ#Q:_Can_I_exchange_Gnucash_file_with_any_other_version_of_GnuCash.3F> and I wondered whether there are any additional limitations in the downgrade path between 3.x and versions of 2.6.x? ISTR reading about some limits there.

Cheers,
David
_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel
Reply | Threaded
Open this post in threaded view
|

Re: [GNC-dev] Compatibility Question

John Ralls-2


> On Oct 15, 2018, at 8:27 AM, David T. via gnucash-devel <[hidden email]> wrote:
>
> Hello,
>
> I am looking at https://wiki.gnucash.org/wiki/FAQ#Q:_Can_I_exchange_Gnucash_file_with_any_other_version_of_GnuCash.3F <https://wiki.gnucash.org/wiki/FAQ#Q:_Can_I_exchange_Gnucash_file_with_any_other_version_of_GnuCash.3F> and I wondered whether there are any additional limitations in the downgrade path between 3.x and versions of 2.6.x? ISTR reading about some limits there.

Yes, that needs some updating. See https://github.com/Gnucash/gnucash/blob/maint/libgnucash/engine/gnc-features.c#L42 <https://github.com/Gnucash/gnucash/blob/maint/libgnucash/engine/gnc-features.c#L42> for the feature flags; the earliest version that supports each is in the description string.

Regards,
John Ralls

_______________________________________________
gnucash-devel mailing list
[hidden email]
https://lists.gnucash.org/mailman/listinfo/gnucash-devel