[GNC] Newly saved file won't load

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[GNC] Newly saved file won't load

David Mills
Hi,

I've been using GNU cash for years and have loved it.

I recently upgraded my Linux from OpenSUSE 42.3 to Leap 15.1.  From memory
I was on GnuCash 2.6.  Now on 3.0-lp151.2.57

When I open an existing file (from the past release) and resave, the saved
file gets an error when opening.  The message is "There was an error
parsing the file ..."

Luckily I have a copy of the previous version.

The file is quite large: 1.9 MB as a gnucash file and 26MB once unzipped.

I have a second set of books (a different entity) that is much smaller (643
KB) and with it I can save and re-open.

I tried opening the old copy of the large file again, running a Check and
repair and then saving.  The result is the same - it won't open.

I have installed release 3.7 on a VirtualBox Windows 10 host and it is able
to load, save and re-open the files that won't open on the OpenSUSE 3.0
version.

Is there some way to resolve the issue on Linux so that I don't have to run
VirtualBox to update my accounting?

Cheers,

David.

 --
Mob: +61-4-11513404
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.
Reply | Threaded
Open this post in threaded view
|

Re: [GNC] Newly saved file won't load

Colin Law
3.0 had a number of significant bugs, though I don't know if that is one of
them. You should upgrade to 3.7 if possible

Colin

On Tue, 8 Oct 2019, 12:23 David Mills, <[hidden email]> wrote:

> Hi,
>
> I've been using GNU cash for years and have loved it.
>
> I recently upgraded my Linux from OpenSUSE 42.3 to Leap 15.1.  From memory
> I was on GnuCash 2.6.  Now on 3.0-lp151.2.57
>
> When I open an existing file (from the past release) and resave, the saved
> file gets an error when opening.  The message is "There was an error
> parsing the file ..."
>
> Luckily I have a copy of the previous version.
>
> The file is quite large: 1.9 MB as a gnucash file and 26MB once unzipped.
>
> I have a second set of books (a different entity) that is much smaller (643
> KB) and with it I can save and re-open.
>
> I tried opening the old copy of the large file again, running a Check and
> repair and then saving.  The result is the same - it won't open.
>
> I have installed release 3.7 on a VirtualBox Windows 10 host and it is able
> to load, save and re-open the files that won't open on the OpenSUSE 3.0
> version.
>
> Is there some way to resolve the issue on Linux so that I don't have to run
> VirtualBox to update my accounting?
>
> Cheers,
>
> David.
>
>  --
> Mob: +61-4-11513404
> _______________________________________________
> gnucash-user mailing list
> [hidden email]
> To update your subscription preferences or to unsubscribe:
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> If you are using Nabble or Gmane, please see
> https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.
>
_______________________________________________
gnucash-user mailing list
[hidden email]
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.